サイトカレンダをスキップ

«
2017年 10月
»
1 2 3 4 5 6 7
8 9 10 11 12 13 14
15 16 17 18 19 20 21
22 23 24 25 26 27 28
29 30 31

-

ログイン

ログイン

QRコード

QR code


 掲示板目次 > Magento全般 > その他 新規投稿 返信投稿
 magento 2.0.2 日本語
 
juntama
 2016年2月25日 14:48 JST (参照数 4752回)  
掲示板 Newbie
Newbie

状態: オフライン


登録日: 2016年2月24日
投稿数: 6
初めて投稿させて頂きます。
つい先ほど、magento 2.0.2をインストールしました。インストレーション途中で日本語指定をしたのですが、日本語が表示されません。どのようにしたら日本語表示できるのか分かる人がいましたら教えてください。
magento 1.9のようなエクステンションがあるのでしょうか?

 
プロフィール メール
引用して書き込む
hirokazu_nishi
 2016年2月25日 22:15 JST  
掲示板 管理者
管理者

状態: オフライン


登録日: 2008年2月 9日
投稿数: 470
Magento2.xの場合は、1.xとは手順が異なります。

現時点ではcomposerをインストールする必要があり、composerが動作する状態で、

 composer require magento-japan/m2-japaneselocale

を実行し、Packagistのロケールパッケージを登録します。
その後、

 composer update

を実行すると日本語ロケールのパッケージがインストールされます。
その後、Magentoのキャッシュをクリアすると、日本語ロケールが当たるはずです。

Magento技術サポート・日本語化エクステンション・セキュリティ診断提供中です。日本語ガイドブックの販売・レンタルサーバサービス開始しました。 http://principle-works.jp/
 
プロフィール メール ホームページ
引用して書き込む
juntama
 2016年2月26日 10:49 JST  
掲示板 Newbie
Newbie

状態: オフライン


登録日: 2016年2月24日
投稿数: 6
ありがとうございます。
早速、実行してみました。が、下記のエラーが出ます。
composer updateを先に実行しても同じエラーです。
$ magento2> sudo composer require magento-japan/m2-japaneselocale
[InvalidArgumentException]
Could not find package magento-japan/m2-japaneselocale at any version for your minimum-stability (a
lpha). Check the package spelling or your minimum-stability


require [--dev] [--prefer-source] [--prefer-dist] [--no-plugins] [--no-progress] [--no-update] [--update-no-dev] [--update-with-dependencies] [--ignore-platform
-reqs] [--sort-packages] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--] [<packages>]...

使用している環境は以下の通りです。
linux-mint 17.3(linux 3.13)
composer 1.0-dev

ちなみにmagento2をインストールした時のコマンドは以下の通りです。
composer create-project --repository-url=https://repo.magento.com/ magento/project-community-edition magento2

なお、sudoにて実行しており、その後、chownコマンドで所有者・グループをApache2.4の実行者であるwww-dataに変更しています。

composerの使い方に慣れていないので、どこかに設定の誤りがあるのかわかりません。magento2というより、composerの使い方に間違いがあるのかもしれません。
さらなる解決策を教えていただけたら、大変、うれしいです。よろしくお願いいたします。

 
プロフィール メール
引用して書き込む
devdev
 2016年2月26日 13:40 JST  
掲示板 Newbie
Newbie

状態: オフライン


登録日: 2016年2月26日
投稿数: 3
こんにちは。最近以下URLの手順でMagento2をインストールした者です。
(composerなどのコマンドは使用しておりません。)

■URL
https://principle-works.jp/blog/how-to-install-magento2-stable/

その際、以下の設定でフロント&バックエンドの両方が日本語化されました。
参考になれば幸いです。

①バックエンド画面より日本語を選択
Magento2バックエンド画面 > 右上の「ユーザ名▼」 > Account Setting(ユーザ名) > Interface Locale > 日本語を選択 > Save Account

②キャッシュクリア
左サイドメニュー > SYSTEM > Cache Management > キャッシュを全てクリア

 
プロフィール メール
引用して書き込む
hirokazu_nishi
 2016年2月26日 19:01 JST  
掲示板 管理者
管理者

状態: オフライン


登録日: 2008年2月 9日
投稿数: 470
すいません、composerコマンドに誤りがありました。

 composer require magento-japan/m2-japaneselocale:dev-master

が正しいです。

> devdevさん
Magento2の正式リリース版には日本語は入ってないはずなんですが、vendor/magento下に、language-ja-jpとかがありますか?

Magento技術サポート・日本語化エクステンション・セキュリティ診断提供中です。日本語ガイドブックの販売・レンタルサーバサービス開始しました。 http://principle-works.jp/
 
プロフィール メール ホームページ
引用して書き込む
devdev
 2016年2月29日 13:14 JST  
掲示板 Newbie
Newbie

状態: オフライン


登録日: 2016年2月26日
投稿数: 3
>hirokazu_nishiさん

確認してみましたが、ja-jpなど日本語っぽいものはなさそうでした。
以下が置いてありました。

language-de_de/
language-fr_fr/
language-zh_hans_cn/
language-en_us/
language-nl_nl/
language-es_es/
language-pt_br/

 
プロフィール メール
引用して書き込む
devdev
 2016年2月29日 13:14 JST  
掲示板 Newbie
Newbie

状態: オフライン


登録日: 2016年2月26日
投稿数: 3
>hirokazu_nishiさん

確認してみましたが、ja-jpなど日本語っぽいものはなさそうでした。
以下が置いてありました。

language-de_de/
language-fr_fr/
language-zh_hans_cn/
language-en_us/
language-nl_nl/
language-es_es/
language-pt_br/

 
プロフィール メール
引用して書き込む
juntama
 2016年3月 5日 08:24 JST  
掲示板 Newbie
Newbie

状態: オフライン


登録日: 2016年2月24日
投稿数: 6
大変返信が遅れてすみません。
当投稿システムで保存ボタンが見つからない状況が続いていました。
今朝、ChromeからFirefoxへブラウザを変えたところプレビューの横に配置されているのがわかりました。
さて、本題です。
下記コマンドで無事、日本語が表示できるようになりました。
magento 2をあきらめて、1.9を使おうと思っていたので、大変、助かりました。
> composer require magento-japan/m2-japaneselocale:dev-master

なお、私の場合、下記の操作をどうすればよいかわからなかったので、
キャッシュのクリア以外、行っていません。
> を実行し、Packagistのロケールパッケージを登録します。その後、
> composer update

ただし、上記コマンド(composer require)を実行する前に、確認のため、下記の操作を行っています。
> ①バックエンド画面より日本語を選択
> Magento2バックエンド画面 > 右上の「ユーザ名▼」 > Account Setting(ユーザ名) > Interface Locale > 日本語を選択 > Save Account

参考ですが、私の記憶に誤りがなければ、devdevさんの方法を2回ほど試しています。
その時、日本語は表示できませんでした。

ありがとうございました。

 
プロフィール メール
引用して書き込む
内容生成: 6.62 秒
新規投稿 返信投稿


通常 通常
注目トピック 注目トピック
ロック済 ロック済
新着 新着
注目トピック 新着 注目トピック 新着
ロック済トピック 新着 ロック済トピック 新着
ゲストユーザの投稿を見る 
ゲストユーザ投稿可能 
HTML許可 
バッドワードをチェック