サイトカレンダをスキップ

«
2017年 12月
»
1 2
3 4 5 6 7 8 9
10 11 12 13 14 15 16
17 18 19 20 21 22 23
24 25 26 27 28 29 30
31

-

ログイン

ログイン

QRコード

QR code


 掲示板目次 > Magento全般 > インストール不具合 新規投稿 返信投稿
 PHP Extension "mcrypt" must be loaded
 
ゲストユーザ: seastar
 2010年8月17日 09:54 JST (参照数 14077回)  



はじめまして。
Magent 初心者&サーバー初心者のSeasterです。
Magentoを導入したいと思いまして、さっそくmagento-1.4.1.1をインストール始めたのですが、Configuration の段階で
PHP Extension "mcrypt" must be loaded
と出てきまして先に進めません。
ネットやこちらの掲示板でもいろいろ調べてみたのですが、具体的な解決方法がでてこなくて、英語も苦手なのでよく判りませんでした。

当方、レンタルの共用サーバー環境で
OS Linux
Apache 2.2.3
MySQL5.0.77
PHP5.2.14
です。

どなたか解決方法をご教示いただけませんでしょうか?
宜しくお願いいたします。

 
引用して書き込む
hirokazu_nishi
 2010年8月17日 20:29 JST  
掲示板 管理者
管理者

状態: オフライン


登録日: 2008年2月 9日
投稿数: 470
mcryptはlibmcryptを使用するPHPのエクステンションですね。
Magentoのインストールには必須になります。

mcryptエクステンションを使うためにはPHPを --enable-mcrypt をつけてコンパイルする必要があります。
標準のRPMとかだと対応してない場合があります。

お使いのサーバでPHPがCGIモードで動作しているのであれば、自力でコンパイルしてインストールする方法があるかもしれませんが、そうでない場合はあきらめるしかないかと思います。

ちなみにどちらのサーバをお使いですか?

Magento技術サポート・日本語化エクステンション・セキュリティ診断提供中です。日本語ガイドブックの販売・レンタルサーバサービス開始しました。 http://principle-works.jp/
 
プロフィール メール ホームページ
引用して書き込む
ゲストユーザ: seastar
 2010年8月17日 20:53 JST  



管理人様
さっそくのご回答誠に有難うございます。
教えていただいた、

>PHPを --enable-mcrypt をつけてコンパイルする

これをキーワードにやり方を探してみます。

ちなみにレンタルサーバーはsixcoreと言うところを使っておりまして、
マニュアルリンク先
http://www.sixcore.ne.jp/shared/man/


かねてからmagentoを使いたくてPHPのバージョンアップのリクエストを出していて、つい最近やっとPHP5.2.14に選択できるようにしていただけました。
(標準ではPHP5.1.6)


>サーバでPHPがCGIモードで動作

これにつきましては、sixcoreのサポートにも伺ってみます。

うまくインストールできましたら、ここにご報告いたします。
どうもありがとうございました。




 
引用して書き込む
ゲストユーザ: seastar
 2010年8月18日 22:24 JST  



さっそく、レンタルサーバーのsixcore カスタマーサポートから連絡が来ました。

PHPのコンパイルには対応しておらず、
※弊社ではシェルの許容はしておらず、コンパイルなどの処理も行っていただくことがかないません。
とのこと Cry

sixcore でMagentoを使うのはあきらめるしかないということですね。
100GB 3780円(sixcore共用)と同程度または5000円くらいまでの価格で、
Magentoを使えるサーバーどこかご存じないでしょうか?

 
引用して書き込む
hirokazu_nishi
 2010年8月18日 23:47 JST  
掲示板 管理者
管理者

状態: オフライン


登録日: 2008年2月 9日
投稿数: 470
やっぱりですか。

100GB 3780円(sixcore共用)と同程度または5000円くらいまでの価格で、
Magentoを使えるサーバーどこかご存じないでしょうか?

VPSで、

・Debian系またはBSD、Soralisをつかっている
・Redhat系でもPHP5.2が入ってるところ。もしくは自分で入れ替えができるところ
・サーバ管理ツール(Webmin・Plesk・HDE等)が入っていないところ。

なら問題ないと思います。
私はLinodeがすぐ使えるのでよく使いますが、ServermanVPSも安いのでいいかもしれません。
(私は試してないので安定度に関しては言及できませんが・・・)

9月からはさくらインターネットもVPSサービスを始めるそうなので、それも候補にできますね。
ただ、現実的なサービスとして運用するのであれば、メモリ1Gはほしいです。

レンタルサーバ(共用)であればオビタスターさんがサービス提供されてます。
こちらはDebian系にFastCGIでの提供になります。
シェルは使えませんが、いろいろそのほかのツールなどが充実してますね。

Magento技術サポート・日本語化エクステンション・セキュリティ診断提供中です。日本語ガイドブックの販売・レンタルサーバサービス開始しました。 http://principle-works.jp/
 
プロフィール メール ホームページ
引用して書き込む
ゲストユーザ: seastar
 2010年8月19日 19:07 JST  



管理人様

詳細に教えていただき有難うございました。

教えていただきました情報をもとにいろいろ調べてみました。
Linodeは海外サーバーなのですね。いろいろな方の評判も良いみたいで、
私には英語なので使いこなせるかどうか不安がありますが、前向きに検討してみます。

さくらインターネットのVPSサービス
ベータの試用申し込み(終了)という案内が出てきたのですが、
9月以降に正式発表されるのでしょうか?
案内が出るまでもう少し様子見てみます。

オビタスターさんクラスになると100GBクラスですと結構お値段が張るのですね。

金額的に、そのほかにもいろいろ調べていたのですが、
ラピッドサイトの
VPS-01(月額2310円/120GB/1GB)
VPS-02(月額4725円/200GB/2GB)
というプランが、root権限もあってPHPのextensionの導入も可能なので、
とりあえず来週辺りに無料お試しサービスで
VPS-01にてMagentoのインストールを試してみます。

ちなみに、同社のRVカスタムシリーズとRV-7シリーズでは動作確認できているようです。http://www.rapidsite.jp/function/app/magento.html

又ご報告いたします。


 
引用して書き込む
内容生成: 1.13 秒
新規投稿 返信投稿


通常 通常
注目トピック 注目トピック
ロック済 ロック済
新着 新着
注目トピック 新着 注目トピック 新着
ロック済トピック 新着 ロック済トピック 新着
ゲストユーザの投稿を見る 
ゲストユーザ投稿可能 
HTML許可 
バッドワードをチェック