サイトカレンダをスキップ

«
2017年 10月
»
1 2 3 4 5 6 7
8 9 10 11 12 13 14
15 16 17 18 19 20 21
22 23 24 25 26 27 28
29 30 31

-

ログイン

ログイン

QRコード

QR code


 掲示板目次 > Magento全般 > インストール不具合 新規投稿 返信投稿
 Magentoconnectの不具合について
 
t_shimizu
 2011年6月27日 00:26 JST (参照数 6715回)  
掲示板 Newbie
Newbie

状態: オフライン


登録日: 2011年6月26日
投稿数: 12
お世話になります。

いろいろと調べてみたのですが、わからずこの掲示板でで質問させていただきます。
よろしくお願いします。

現在、AWS(EC2)においてubuntu上にmagento ver1.4.1.0をインストールしております。
これからテーマ等を変えたいと思い、Magentoconnectを使いたいのですが、Extension Keyを入力し、[Install]ボタンを押すと下の黒画面に

downloading magento_classic_theme_free-1.4.1.0.tgz ...
Starting to download magento_classic_theme_free-1.4.1.0.tgz (3,687,904 bytes)
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . ...done: 3,687,904 bytes
ERROR: unable to unpack /var/www/magento/downloader/pearlib/download/magento_classic_theme_free-1.4.1.0.tgz

と表示され、エラーになってしまいます。サーバ上では上記ディレクトリにtgzファイルと展開フォルダは存在しています。
なぜ、エラーになってしまうのでしょうか。

Magentoフォルダはすべて777に設定してあります。
また、Magentoフォルダ全体のパーミッションを777に設定することによるセキュリティーの問題点はないのでしょうか?
Magentoconnectを使い終わった後に775に設定し直した方が良いのでしょうか?

申し訳ございませんが、ご教示のほどお願い致します。

 
プロフィール メール
引用して書き込む
t_shimizu
 2011年6月30日 11:33 JST  
掲示板 Newbie
Newbie

状態: オフライン


登録日: 2011年6月26日
投稿数: 12
解決しましたので自己レスです。

magento/downloader/pearlib/php/Archive/Tar.php
このファイルを書きサイトからダウンした物と差し替えます。
http://www.curtmaybury.co.uk/2011/06/magento-connect-downloader-1-4-unable-to-unpack/

詳しい原因は私には分かりません。

以上です。

 
プロフィール メール
引用して書き込む
hirokazu_nishi
 2011年7月 2日 14:33 JST  
掲示板 管理者
管理者

状態: オフライン


登録日: 2008年2月 9日
投稿数: 470
Tar.phpということは、tarボールの展開で不具合があるということでしょうね。
ちなみに、1.4.1.0は1.4.1.1という修正版が出ているので、そちらを使うほうが無難です。

また、1.4.1自体もすでに1.4.2や1.5.0、1.5.1が出ているので、できれば新しいものを使うほうが機能追加やパフォーマンスアップ、不具合改修が進んでいるので安心出来ると思いますよ。

Magento技術サポート・日本語化エクステンション・セキュリティ診断提供中です。日本語ガイドブックの販売・レンタルサーバサービス開始しました。 http://principle-works.jp/
 
プロフィール メール ホームページ
引用して書き込む
t_shimizu
 2011年7月 3日 03:57 JST  
掲示板 Newbie
Newbie

状態: オフライン


登録日: 2011年6月26日
投稿数: 12
hirokazu_nishi様
お世話になります。

アドバイスに従いまして、1.4.2.0にバージョンを上げました。
エクステンションやテーマ等に影響があるかと思い最新にはしませんでした。凡例も1.4系の方が多そうですし Big Grin

ありがとうございました。

 
プロフィール メール
引用して書き込む
内容生成: 4.30 秒
新規投稿 返信投稿


通常 通常
注目トピック 注目トピック
ロック済 ロック済
新着 新着
注目トピック 新着 注目トピック 新着
ロック済トピック 新着 ロック済トピック 新着
ゲストユーザの投稿を見る 
ゲストユーザ投稿可能 
HTML許可 
バッドワードをチェック